[Forgot Password]
Login  Register Subscribe

24547

 
 

132763

 
 

126291

 
 

909

 
 

105100

 
 

152

Paid content will be excluded from the download.


Download | Alert*
OVAL

Arbitrary code execution vulnerability via .gitmodules - CVE-2018-17456

ID: oval:org.secpod.oval:def:48098Date: (C)2018-10-17   (M)2019-02-06
Class: VULNERABILITYFamily: unix




Git is a distributed revision control system with a decentralized architecture. As opposed to centralized version control systems with a client-server model, Git ensures that each working copy of a Git repository is an exact copy with complete revision history. This not only allows the user to work on and contribute to projects without the need to have permission to push the changes to their official repositories, but also makes it possible for the user to work with no network connection. Security Fix: * git: arbitrary code execution when recursively cloning a malicious repository For more details about the security issue, including the impact, a CVSS score, and other related information, refer to the CVE page listed in the References section.

Platform:
Red Hat Enterprise Linux 7
CentOS 7
Product:
git
Reference:
CVE-2018-17456
CVE    1
CVE-2018-17456
CPE    15
cpe:/a:git:git
cpe:/o:redhat:enterprise_linux:6
cpe:/o:debian:debian_linux:9.0
cpe:/o:canonical:ubuntu_linux:16.04::~~lts~~~
...

© SecPod Technologies